Spring Web Flow
  1. Spring Web Flow
  2. SWF-1391

issues regarding https://jira.springframework.org/browse/SWF-1383 fix

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Invalid
    • Affects Version/s: 2.2.0.M1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      After the fix, I can start my application. The home page is a non-swf request. So the original issue is fixed. But after I login, I can not start spring web flow. I got the following exceptions.

      [8/27/10 10:02:37:562 CDT] 00000036 ServiceLogger I com.ibm.ws.ffdc.IncidentStreamImpl open FFDC0009I: FFDC opened incident stream file C:\Program Files\IBM\SDP\runtimes\base_v61\profiles\AppSrv03\logs\ffdc\server1_00000036_10.08.27_10.02.37_0.txt
      [8/27/10 10:02:37:578 CDT] 00000036 ServiceLogger I com.ibm.ws.ffdc.IncidentStreamImpl resetIncidentStream FFDC0010I: FFDC closed incident stream file C:\Program Files\IBM\SDP\runtimes\base_v61\profiles\AppSrv03\logs\ffdc\server1_00000036_10.08.27_10.02.37_0.txt
      [8/27/10 10:02:37:625 CDT] 00000036 ServiceLogger I com.ibm.ws.ffdc.IncidentStreamImpl open FFDC0009I: FFDC opened incident stream file C:\Program Files\IBM\SDP\runtimes\base_v61\profiles\AppSrv03\logs\ffdc\server1_00000036_10.08.27_10.02.37_1.txt
      [8/27/10 10:02:37:640 CDT] 00000036 ServiceLogger I com.ibm.ws.ffdc.IncidentStreamImpl resetIncidentStream FFDC0010I: FFDC closed incident stream file C:\Program Files\IBM\SDP\runtimes\base_v61\profiles\AppSrv03\logs\ffdc\server1_00000036_10.08.27_10.02.37_1.txt
      [8/27/10 10:02:37:687 CDT] 00000036 ServiceLogger I com.ibm.ws.ffdc.IncidentStreamImpl open FFDC0009I: FFDC opened incident stream file C:\Program Files\IBM\SDP\runtimes\base_v61\profiles\AppSrv03\logs\ffdc\server1_00000036_10.08.27_10.02.37_2.txt
      [8/27/10 10:02:37:734 CDT] 00000036 ServiceLogger I com.ibm.ws.ffdc.IncidentStreamImpl resetIncidentStream FFDC0010I: FFDC closed incident stream file C:\Program Files\IBM\SDP\runtimes\base_v61\profiles\AppSrv03\logs\ffdc\server1_00000036_10.08.27_10.02.37_2.txt
      [8/27/10 10:02:37:750 CDT] 00000036 WebApp E [Servlet Error]-[Spring MVC Dispatcher Servlet]: org.springframework.webflow.execution.FlowExecutionException: Exception thrown in state 'donorLoginHome' of flow 'donorLogin'
      at org.springframework.webflow.engine.impl.FlowExecutionImpl.wrap(FlowExecutionImpl.java:569)
      at org.springframework.webflow.engine.impl.FlowExecutionImpl.resume(FlowExecutionImpl.java:263)
      at org.springframework.webflow.executor.FlowExecutorImpl.resumeExecution(FlowExecutorImpl.java:169)
      at org.springframework.webflow.mvc.servlet.FlowHandlerAdapter.handle(FlowHandlerAdapter.java:183)
      at org.springframework.webflow.mvc.servlet.FlowController.handleRequest(FlowController.java:174)
      at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:48)
      at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:774)
      at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:719)
      at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:644)
      at org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:549)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
      at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:1146)
      at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:1087)
      at com.ibm.ws.webcontainer.filter.WebAppFilterChain.doFilter(WebAppFilterChain.java:145)
      at com.baxter.biolife.easyscheduler.presentation.util.SessionFilter.doFilter(SessionFilter.java:104)
      at com.ibm.ws.webcontainer.filter.FilterInstanceWrapper.doFilter(FilterInstanceWrapper.java:190)
      at com.ibm.ws.webcontainer.filter.WebAppFilterChain.doFilter(WebAppFilterChain.java:130)
      at com.ibm.ws.webcontainer.filter.WebAppFilterChain._doFilter(WebAppFilterChain.java:87)
      at com.ibm.ws.webcontainer.filter.WebAppFilterManager.doFilter(WebAppFilterManager.java:840)
      at com.ibm.ws.webcontainer.filter.WebAppFilterManager.doFilter(WebAppFilterManager.java:683)
      at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:589)
      at com.ibm.ws.wswebcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:534)
      at com.ibm.ws.webcontainer.servlet.CacheServletWrapper.handleRequest(CacheServletWrapper.java:90)
      at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:751)
      at com.ibm.ws.wswebcontainer.WebContainer.handleRequest(WebContainer.java:1478)
      at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:126)
      at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:458)
      at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewInformation(HttpInboundLink.java:387)
      at com.ibm.ws.http.channel.inbound.impl.HttpICLReadCallback.complete(HttpICLReadCallback.java:102)
      at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:165)
      at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:217)
      at com.ibm.io.async.AsyncChannelFuture.fireCompletionActions(AsyncChannelFuture.java:161)
      at com.ibm.io.async.AsyncFuture.completed(AsyncFuture.java:136)
      at com.ibm.io.async.ResultHandler.complete(ResultHandler.java:196)
      at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:751)
      at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:881)
      at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1497)
      Caused by: java.lang.NullPointerException
      at org.springframework.faces.webflow.JsfViewFactory.getView(JsfViewFactory.java:76)
      at org.springframework.webflow.engine.ViewState.resume(ViewState.java:215)
      at org.springframework.webflow.engine.Flow.resume(Flow.java:545)
      at org.springframework.webflow.engine.impl.FlowExecutionImpl.resume(FlowExecutionImpl.java:259)
      ... 36 more

        Activity

        Rossen Stoyanchev added a comment -

        It looks like your FacesContext is null. It's probably because you'r missing some configuration. Please, see booking-faces sample configuration. Specifically the FlowFacesContextLifecycleListener in webflow-config.xml.

        James added a comment -

        I replaced with SWF 2.1 jar files. Everthing works fine. I am trying to invoke SWF from Spring MVC at this point. Since I cannot start SWF directly from faces-config.xml navigation redirect, I first redirect to a html page via Spring MVC servlet from faces-config.xml and then redirect to SWF from that page. It will be nice if SWF support redirect from faces-config.xml navigation.

        See the exception.

        org.springframework.webflow.execution.FlowExecutionException: Exception thrown in state 'donorLoginHome' of flow 'donorLogin'

        donorLoginHome is the first state in my donorLogin.xml flow definiton.

        Rossen Stoyanchev added a comment -

        Unless you have any further comments on the original description of this issue, I am going to close it. The issue is most likely due to missing FlowFacesContextLifecycleListener configuration.

        James added a comment -

        You are right. This issue can be closed. thanks.

        Rossen Stoyanchev added a comment -

        Closing this issue as it doesn't appear to be a bug. FWIW there are plans to make this configuration easier for 2.2.0.RC1 SWF-1375.


          People

          • Assignee:
            Rossen Stoyanchev
            Reporter:
            James
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development