Spring Web Flow
  1. Spring Web Flow
  2. SWF-1426

PrimeFaces' commandButton does not work on view transition in Internet Explorer.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Complete
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.3.0
    • Component/s: None
    • Labels:
      None

      Description

      I got this primefaces button configured in pageOne.xhtml:

          <p:commandButton type="submit" value="Next" action="next" />
      

      And my flow configuration is like this:

          <view-state id="pageOne">
      	<transition on="next" to="pageTwo" />
          </view-state>
      
          <view-state id="pageTwo" />
      

      The view transition works nicely in FireFox, Chrome, and Safari, but it fails in IE8.

        Issue Links

          Activity

          Sascha Steiger added a comment -

          The workaround with ajax="false" doesn't work in all cases:

          This is the case (can be easily checked with booking-faces):

          2 p:commandButtons, one with "Search"-action and one with "Cancel"-action, both with ajax="false"

          • everytime I click on the Search-button, the cancel-action/transition is triggered.
          • If I change the order of the buttons (Cancel, Search), a click on Cancel triggers the search-action/transition

          Hope this helps to find the cause.

          Rossen Stoyanchev added a comment -

          I can't reproduce the issue with 2 p:commandButtons. Each button triggers the right transition for me.

          Suman Sohal added a comment -

          can someone please provide a good feasible solution because by turning AJAX off how one gonna use the ajax capabilities of PRIMEFACES.

          Rossen Stoyanchev added a comment - - edited

          The status of this issue is "Complete". It will be available in the 2.3.0 release. In the mean time as an alternative you can use a plain JSF command link with an <f:ajax> element within it.

          Cagatay Civici added a comment -

          I couldn't manage to replicate this issue from PrimeFaces side, first ajax redirect work fine on PrimeFaces Showcase with all browsers including IE8. Showcase doesn't have WebFlow so tried with booking-faces maintenance 3 on IE8 which also worked.

          In summary all transitions work fine with SWF 2.3.0 SNAPSHOT, PrimeFaces 2.2.RC2.


            People

            • Assignee:
              Rossen Stoyanchev
              Reporter:
              Donny A. Wijaya
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development