Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: 2.4.1
    • Fix Version/s: 2.4.2
    • Component/s: Security
    • Labels:
      None

      Description

      2.4.0.RELEASE used WSS4J 2.1.4, but 2.4.1 has jumped to 2.2. Generally speaking, a minor upgrade to a dependency in a maintenance release should be avoided. IMO, 2.4.2 should revert to 2.1.x.

        Activity

        awilkinson Andy Wilkinson created issue -
        awilkinson Andy Wilkinson made changes -
        Field Original Value New Value
        Description 2.4.0.RELEASE used WSS4J 2.1.4, but 2.4.1 has jumped to 2.2. Generally speaking, minor upgrade in a maintenance release should be avoided. IMO, 2.4.2 should revert to 2.1.x. 2.4.0.RELEASE used WSS4J 2.1.4, but 2.4.1 has jumped to 2.2. Generally speaking, a minor upgrade to a dependency in a maintenance release should be avoided. IMO, 2.4.2 should revert to 2.1.x.
        gregturn Greg Turnquist made changes -
        Assignee Greg Turnquist [ gregturn ]
        gregturn Greg Turnquist made changes -
        Fix Version/s 2.4.2 [ 16502 ]
        gregturn Greg Turnquist made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        gregturn Greg Turnquist made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Complete [ 8 ]
        gregturn Greg Turnquist made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            gregturn Greg Turnquist
            Reporter:
            awilkinson Andy Wilkinson
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: