Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: 2.4.1
    • Fix Version/s: 2.4.2
    • Component/s: Security
    • Labels:
      None

      Description

      2.4.0.RELEASE used WSS4J 2.1.4, but 2.4.1 has jumped to 2.2. Generally speaking, a minor upgrade to a dependency in a maintenance release should be avoided. IMO, 2.4.2 should revert to 2.1.x.

        Activity

        Hide
        gregturn Greg Turnquist added a comment -

        Rolled back 2.x branch's wss4j2 to 2.1.11, the latest version of the 2.1 branch.

        Show
        gregturn Greg Turnquist added a comment - Rolled back 2.x branch's wss4j2 to 2.1.11, the latest version of the 2.1 branch.

          People

          • Assignee:
            gregturn Greg Turnquist
            Reporter:
            awilkinson Andy Wilkinson
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: