Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-128

A SOAP:Fault does not set the the response code to 500

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.0 RC1
    • Fix Version/s: 1.0 RC2
    • Component/s: None
    • Labels:
      None

      Description

      Whenever a SOAP Fault is returned on the server side, the server error code is not set to 500. This does not comply with WS-I.

      See http://forum.springframework.org/showthread.php?t=39122

        Activity

        Hide
        arjen.poutsma Arjen Poutsma added a comment -

        Fixed. The server used to set the response status code after the body of the message had been written. Now it is written before, like it should.

        Show
        arjen.poutsma Arjen Poutsma added a comment - Fixed. The server used to set the response status code after the body of the message had been written. Now it is written before, like it should.
        Hide
        arjen.poutsma Arjen Poutsma added a comment -

        Closing 1.0 RC2 issues.

        Show
        arjen.poutsma Arjen Poutsma added a comment - Closing 1.0 RC2 issues.
        Hide
        bibinsga25 Bibin added a comment -

        Fix is broken, using version 2.1.2, running on websphere application server. SoapFaults are returned with 200 code.

        Show
        bibinsga25 Bibin added a comment - Fix is broken, using version 2.1.2, running on websphere application server. SoapFaults are returned with 200 code.

          People

          • Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            arjen.poutsma Arjen Poutsma
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: