Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0 M3
    • Fix Version/s: 1.0
    • Component/s: Core
    • Labels:
      None
    • Environment:
      JDK 1.4.2
      Weblogic 8.1.3
      Spring-WS 1.0-M3

      Description

      The following exception occurred when attempting to add a header to the response message:

      29 Jun 2007 20:38:04,897 DEBUG MessageDispatcherServlet []: Could not complete request
      java.lang.NoSuchMethodError: javax.xml.soap.SOAPElement.getVisibleNamespacePrefixes()Ljava/util/Iterator;
      at org.springframework.ws.soap.saaj.support.SaajUtils.toName(SaajUtils.java:122)
      at org.springframework.ws.soap.saaj.Saaj11Implementation.addHeaderElement(Saaj11Implementation.java:109)
      at org.springframework.ws.soap.saaj.SaajSoapHeader.addHeaderElement(SaajSoapHeader.java:54)
      ...

      The problem is in SaajUtils.java, line 122:

      Iterator prefixes = resolveElement.getVisibleNamespacePrefixes();

      However, getVisibleNamespacePrefixes() is not available in SAAJ 1.1.

      I will submit a patch shortly.

        Activity

        jpeterson Jeff Peterson added a comment -

        A simple workaround:

        When calling addHeaderElement(QName), make sure the QName prefix is set to a non-empty string.

        arjen.poutsma Arjen Poutsma added a comment -

        Fixed. SaajUtils now uses getNamespacePrefixes() under SAAJ 1.1.

        arjen.poutsma Arjen Poutsma added a comment -

        Closing issues for 1.0.0


          People

          • Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            jpeterson Jeff Peterson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: