Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0 M1
    • Component/s: Core
    • Labels:
      None

      Description

      Currently, the only implementation of the SoapMessage interface is SaajSoapMessage. SAAJ uses an DOM underneath, which is not very efficient when handling larger messages. A Streaming model, using StAX, is much more suitable for these larger messages.

      We should provide such a streaming message model. It should be configurable whether the message payload should be cached or not. When cached, the message payload can be read multiple times. When it is not cached, it can only be read once. It should always be possible to read the message headers multiple times, since headers are required for interceptor handling.

        Activity

        arjen.poutsma Arjen Poutsma added a comment -

        I've implemented this based on AXIS2's Object Model (AXIOM). Despite the bad press AXIS2 seems to get in the blogs, the AXIOM model is pretty decent. And it supports SOAP 1.2 too.

        The only remaining issue is related to SOAP Faults when using SOAP 1.1. I've reported an issue for it here:
        http://issues.apache.org/jira/browse/WSCOMMONS-38

        Another thing that needs to be done is attachment support for Axiom. I will implement that soon.

        arjen.poutsma Arjen Poutsma added a comment -

        Apparently, the SOAP Fault thing is not a bug, but a feature, since Axiom deals with all SOAP messages as being SOAP 1.2 internally.

        arjen.poutsma Arjen Poutsma added a comment -

        Done.


          People

          • Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            arjen.poutsma Arjen Poutsma
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: