Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-22

setValidating(boolean) is deprecated in JAXB 2

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.1
    • Fix Version/s: 1.0 M1
    • Component/s: OXM
    • Labels:
      None
    • Environment:
      Java 5, JAXB 2 (Sun RI)

      Description

      When the method setValidation(boolean) of JaxbMarshaller is called it always throws an UnsupportedOperationException, due the fact that the JAXB has deprecated the similar method of java.xml.bind.Unmarshaller and the Sun's JAXB implementation throws that exception.

      The problem is that the setValidation(boolean) method of JaxbMarshaller is being called in afterPropertiesSer() method, so the JaxbMarshaller cannot be instatiated by spring.

        Activity

        arjen.poutsma Arjen Poutsma added a comment -

        Change the title of the issue to something more descriptive.


          People

          • Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            routis Routis Haralampos
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: