Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.5 M1
    • Component/s: None
    • Labels:
      None

      Description

      We should let the Jaxb1Marshaller and Jaxb2Marshaller implement BeanClassLoaderAware, and use that classloader for JAXBContext construction.

      Planned for 1.1, since BeanClassLoaderAware is Spring 2.0+, and we drop 1.2.9 support in 1.1

        Activity

        Hide
        arjen.poutsma Arjen Poutsma added a comment -

        Closing issues for 1.5.0 M1

        Show
        arjen.poutsma Arjen Poutsma added a comment - Closing issues for 1.5.0 M1

          People

          • Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            arjen.poutsma Arjen Poutsma
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: