Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-245

SAXParseException when using HttpURLConnection

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.2
    • Fix Version/s: 1.5 M1, 1.0.3
    • Component/s: Core
    • Labels:
      None
    • Environment:
      JRE 1.4 Spring 2.0.7 JAXB 1 SAAJ 1.2

      Description

      When using the HttpUrlConnection in combination with the WebServiceTemplate, the following exception occurs:

      org.xml.sax.SAXParseException: The root element is required in a well-formed document

      This seems to occur in Java 1.4, using SAAJ 1.2. A detailed description of the issue is available at http://forum.springframework.org/showthread.php?t=40413&page=2

        Issue Links

          Activity

          arjen.poutsma Arjen Poutsma added a comment -

          Fixed in 1.5 M1 and 1.0.3.

          arjen.poutsma Arjen Poutsma added a comment -

          Fixed, for real this time.

          arjen.poutsma Arjen Poutsma added a comment -

          Closing issues for 1.5.0 M1


            People

            • Assignee:
              arjen.poutsma Arjen Poutsma
              Reporter:
              arjen.poutsma Arjen Poutsma
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: