Details

    • Type: New Feature
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0 M1
    • Fix Version/s: 1.0 M2
    • Component/s: Core
    • Labels:
      None

      Description

      It appears SAAJ 1.3 has been released at https://saaj.dev.java.net/. It includes SOAP 1.2 and MTOM support.

      We should upgrade to SAAJ 1.3, but not create any hardcoded depencies on it . This will probably require writing a SaajVersion class, just like JaxpVersion in xml and JdkVersion in spring core.

        Issue Links

          Activity

          Hide
          arjen.poutsma Arjen Poutsma added a comment -

          This turned out to be harder than expected. SAAJ 1.3 implements SOAP 1.2 really stricly, more so than Axiom's SOAP 1.2 implementation. As a result, some changes in the SoapFault API were necessary, since SOAP 1.2 only allows for a limited set of fault codes. Custom fault codes are not longer possible in SOAP 1.2, custom fault subcodes are.

          Show
          arjen.poutsma Arjen Poutsma added a comment - This turned out to be harder than expected. SAAJ 1.3 implements SOAP 1.2 really stricly, more so than Axiom's SOAP 1.2 implementation. As a result, some changes in the SoapFault API were necessary, since SOAP 1.2 only allows for a limited set of fault codes. Custom fault codes are not longer possible in SOAP 1.2, custom fault subcodes are.

            People

            • Assignee:
              arjen.poutsma Arjen Poutsma
              Reporter:
              arjen.poutsma Arjen Poutsma
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: