Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-300

SAAJ0539: Unable to get header stream in saveChanges

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 1.5.1
    • Component/s: Core
    • Labels:
      None
    • Environment:
      Sun SPARC, Oracle AS, Web application (WAR) on OC4J Component

      Description

      at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:824)
      at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:330)
      at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:830)
      at com.evermind.server.http.AJPRequestHandler.run(AJPRequestHandler.java:224)
      at com.evermind.server.http.AJPRequestHandler.run(AJPRequestHandler.java:133)
      at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:186)
      at java.lang.Thread.run(Thread.java:534)
      Caused by: com.sun.xml.messaging.saaj.SOAPExceptionImpl: Unable to get header stream in saveChanges:
      at com.sun.xml.messaging.saaj.soap.MessageImpl.saveChanges(MessageImpl.java:541)
      at com.sun.xml.messaging.saaj.soap.MessageImpl.writeTo(MessageImpl.java:591)
      at labware.connector.j2c.LIMSSOAPWrapper.createSOAPFromCallDetails(LIMSSOAPWrapper.java:391)
      ... 28 more
      Caused by: java.io.IOException
      at com.sun.xml.messaging.saaj.soap.impl.EnvelopeImpl.output(EnvelopeImpl.java:240)
      at com.sun.xml.messaging.saaj.soap.SOAPPartImpl.getContentAsStream(SOAPPartImpl.java:202)
      at com.sun.xml.messaging.saaj.soap.MessageImpl.getHeaderBytes(MessageImpl.java:461)
      at com.sun.xml.messaging.saaj.soap.MessageImpl.saveChanges(MessageImpl.java:538)
      ... 30 more

        Activity

        jsanghav JIGNESH created issue -
        jsanghav JIGNESH made changes -
        Field Original Value New Value
        Attachment log.txt [ 13719 ]
        jsanghav JIGNESH added a comment -

        We have deployed a web application on OC4J >> Oracle Application Server. This application runs fine with Tomcat. When we deployed on OAS, it is raising above exception. Please give solution. Thanks

        arjen.poutsma Arjen Poutsma made changes -
        Component/s Core [ 10150 ]
        Component/s XML [ 10200 ]
        Remaining Estimate 1d [ 28800 ]
        Original Estimate 1d [ 28800 ]
        Fix Version/s 1.5.1 [ 10917 ]
        arjen.poutsma Arjen Poutsma added a comment -

        Which version of Spring-WS is this?

        arjen.poutsma Arjen Poutsma added a comment -

        I cannot reproduce this. Make sure you have Xerces 2.8.1 and Xalan 2.7.0 on the classpath, and that they override the OC4J versions. That always does the trick for me.

        arjen.poutsma Arjen Poutsma made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        arjen.poutsma Arjen Poutsma made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        arjen.poutsma Arjen Poutsma added a comment -

        I cannot reproduce this. Make sure you have Xerces 2.8.1 and Xalan 2.7.0 on the classpath, and that they override the OC4J versions. That always does the trick for me.

        arjen.poutsma Arjen Poutsma made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        arjen.poutsma Arjen Poutsma added a comment -

        Closing issues for 1.5.1

        arjen.poutsma Arjen Poutsma made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        59d 18h 1m 1 Arjen Poutsma 27/Apr/08 11:08 PM
        Resolved Resolved Reopened Reopened
        19s 1 Arjen Poutsma 27/Apr/08 11:09 PM
        Reopened Reopened Resolved Resolved
        9s 1 Arjen Poutsma 27/Apr/08 11:09 PM
        Resolved Resolved Closed Closed
        7d 22h 11m 1 Arjen Poutsma 05/May/08 9:20 PM

          People

          • Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            jsanghav JIGNESH
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: