Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-315

Endpointsextending AbstractMarshallingPayloadEndpoint require a marshaller also for oneway style service

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.5 RC1
    • Fix Version/s: 1.5 RC2
    • Component/s: OXM
    • Labels:
      None

      Description

      I can implement a oneway style web service (i.e. event notification) simply returning null in an Endpoint extending AbstractMarshallingPayloadEndpoint.
      The problem is that when configuring the bean in spring-ws-servlet.xml I would like to define only an unmarshaller as I will never return nothing, but Spring Web Services requires a marshaller anyway even if it will never be used.
      A specular problem is in WebServiceTemplate configuration where I would need only a marshaller but I must config also an unmarshaller.

        Activity

        arjen.poutsma Arjen Poutsma added a comment -

        Closing issues for 1.5.


          People

          • Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            montebove Luciano Montebove
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: