Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-459

Spring 1.5.x should depend on Spring 2.0.x as a minimum requirement

    Details

    • Type: Refactoring
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.5.6
    • Component/s: Core
    • Labels:
      None

      Description

      Spring 1.5.x should depend on Spring 2.0.x as a minimum requirement and not Spring 2.5.x.

      Log4J trace logging causes problems when using Spring 2.0.x because the toURI() method in org.springframework.util.ResourceUtils is not available in Spring core 2.0.x.

      As a workaround, changing the log level to INFO should resolve the issue.

      We should run the test suite against Spring 2.0.x to see if other problems arise.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tareq Tareq Abedrabbo
                Reporter:
                sschmidt Stefan Schmidt
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: