Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9
    • Fix Version/s: 0.9.1
    • Component/s: Core, OXM
    • Labels:
      None

      Description

      Currently, Spring-WS is dependent on JAXP 1.3 (for instance, in the PayloadValidatingInterceptor, which uses a javax.xml.validation.Validator)

      This dependency can be resolved by either using JDK 1.5, or by using the Endorsed Standards Override Mechanism to override the JAXP version of your JDK. More information about this override mechanism can be found here:

      http://xerces.apache.org/xerces2-j/faq-general.html#faq-4
      http://java.sun.com/j2se/1.4/docs/guide/standards/

      The solution mentioned above is just a workaround: we should abstract away from this dependency.

        Attachments

          Activity

            People

            • Assignee:
              arjen.poutsma Arjen Poutsma
              Reporter:
              arjen.poutsma Arjen Poutsma
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: