Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-579

AxiomSoapMessageFactory does not parse application/xop+xml Content-Type properly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.8
    • Fix Version/s: 1.5.9
    • Component/s: None
    • Labels:
      None
    • Environment:
      Weblogic 10.3

      Description

      AxiomSoapMessageFactory#getCharSetEncoding(), when given the following HTTP Content-Type header (which I assume is valid),

      application/xop+xml;type="text/xml; charset=utf-8"

      returns a CharSet of 'utf-8"' instead of 'utf-8' (i.e. there is an erroneous double quote at the end of the string).

        Activity

        artbristol Art O Cathain created issue -
        arjen.poutsma Arjen Poutsma made changes -
        Field Original Value New Value
        Fix Version/s 1.5.9 [ 11296 ]
        arjen.poutsma Arjen Poutsma made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        arjen.poutsma Arjen Poutsma made changes -
        Time Spent 13m [ 780 ]
        Remaining Estimate 0d [ 0 ]
        arjen.poutsma Arjen Poutsma made changes -
        Resolution Fixed [ 1 ]
        Status In Progress [ 3 ] Resolved [ 5 ]
        arjen.poutsma Arjen Poutsma made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            artbristol Art O Cathain
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0d
              0d
              Logged:
              Time Spent - 13m
              13m