Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-579

AxiomSoapMessageFactory does not parse application/xop+xml Content-Type properly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.8
    • Fix Version/s: 1.5.9
    • Component/s: None
    • Labels:
      None
    • Environment:
      Weblogic 10.3

      Description

      AxiomSoapMessageFactory#getCharSetEncoding(), when given the following HTTP Content-Type header (which I assume is valid),

      application/xop+xml;type="text/xml; charset=utf-8"

      returns a CharSet of 'utf-8"' instead of 'utf-8' (i.e. there is an erroneous double quote at the end of the string).

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        18d 21h 18m 1 Arjen Poutsma 10/Nov/09 12:53 AM
        In Progress In Progress Resolved Resolved
        14m 4s 1 Arjen Poutsma 10/Nov/09 1:07 AM
        Resolved Resolved Closed Closed
        906d 5h 56m 1 Arjen Poutsma 04/May/12 7:03 AM

          People

          • Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            artbristol Art O Cathain
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0d
              0d
              Logged:
              Time Spent - 13m
              13m