Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-671

Stacktrace in response instead of soap fault

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: 1.5.9
    • Fix Version/s: 2.0.4
    • Component/s: Core
    • Labels:
      None

      Description

      The webservice responds with a stacktrace instead of a soap fault if malformed xml is sent.

        Issue Links

          Activity

          sylvestris Martin Flower created issue -
          walnutmon Justin Boyd added a comment -

          We currently have SOAP services in production that still provide a stack-trace when malformed XML is sent to them - this is a very difficult bug to deal with and there is currently no work-around

          johntylerbush john bush added a comment -

          This ruined a better part of my day. The endpoint resolvers are pretty useless. This really needs to be fixed. I had to extend the servlet to get around this, feels totally hacky, but can't sort out any other way.

          tedpennings Ted Pennings added a comment -

          John, not sure if it's too late to help, but you could create a servlet filter and wrap the chain.doFilter() method in a try-catch block for NestedServletException. You can look at the cause to see if it's an invalid XML related issue, and take action that way. It's slightly better than having to extend the MessageDispatcherServlet, but really not by much. It would be nice to see this issue resolved.

          arjen.poutsma Arjen Poutsma made changes -
          Field Original Value New Value
          Fix Version/s 2.1 M1 [ 11748 ]
          arjen.poutsma Arjen Poutsma made changes -
          Assignee Arjen Poutsma [ arjen.poutsma ]
          arjen.poutsma Arjen Poutsma made changes -
          Fix Version/s 2.2 M1 [ 12850 ]
          Fix Version/s 2.1 M1 [ 11748 ]
          slsh Jarkko Rantavuori added a comment -

          What I have done is to define a custom MessageReceiverHandlerAdapter that is used by the default spring-ws MessageDispatcherServlet. That works and I think is the way to handle this by design. I can provide the code if needed.

          arjen.poutsma Arjen Poutsma added a comment -

          As of version, Spring-WS throws a InvalidXmlException when dealing with invalid XML. By default, this exception results in a 400 status code, but it can be changed by overriding WebServiceMessageReceiverHandlerAdapter.handleInvalidXmlException,

          arjen.poutsma Arjen Poutsma made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 2.0.4 [ 12628 ]
          Fix Version/s 2.2 [ 12850 ]
          Resolution Complete [ 8 ]
          arjen.poutsma Arjen Poutsma made changes -
          Link This issue is duplicated by SWS-688 [ SWS-688 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          1187d 1h 47m 1 Arjen Poutsma 18/Mar/14 3:57 AM

            People

            • Assignee:
              arjen.poutsma Arjen Poutsma
              Reporter:
              sylvestris Martin Flower
            • Votes:
              6 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: