Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-705

OSGi import of org.springframework.security.authentication seems to be the wrong version

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0 GA
    • Fix Version/s: 2.0.2
    • Component/s: Security
    • Labels:
      None
    • Environment:
      Virgo OSGi

      Description

      I'm using an OSGi bundle from the Springsource Enterprise Bundle Repository, org.springframework.ws.soap.security_2.0.0.RELEASE . This bundle imports the package org.springframework.security.authentication at version="[2.0.0,3.0.0)" (to clarify, this means greater than or equal to 2.0.0 and less than 3.0.0). This same import information still seems to be in the Spring WS trunk. The org.springframework.security.authentication package is provided by Spring Security Core, but that package doesn't seem to exist in versions of Spring Securtiy Core prior to 3.0.0. This is causing org.springframework.ws.soap.security to be unable to resolve its dependency on Spring Security Core.

        Activity

        Hide
        asutula Aaron Sutula added a comment -

        Looking at this more, I see the Spring WS parent pom specifies use of Spring Security Core 3.0.2. So the issue seems to be that the template.mf file for the Spring WS security module was not updated to reflect that: https://fisheye.springsource.org/browse/spring-ws/trunk/security/template.mf?hb=true. It still constrains use of Spring Security Core from [2.0.0-3.0.0).

        Show
        asutula Aaron Sutula added a comment - Looking at this more, I see the Spring WS parent pom specifies use of Spring Security Core 3.0.2. So the issue seems to be that the template.mf file for the Spring WS security module was not updated to reflect that: https://fisheye.springsource.org/browse/spring-ws/trunk/security/template.mf?hb=true . It still constrains use of Spring Security Core from [2.0.0-3.0.0).
        Hide
        arjen.poutsma Arjen Poutsma added a comment -

        This is now fixed: I changed the OSGi range to [3.0.0, 4.0.0)

        Show
        arjen.poutsma Arjen Poutsma added a comment - This is now fixed: I changed the OSGi range to [3.0.0, 4.0.0)
        Hide
        arjen.poutsma Arjen Poutsma added a comment -

        Closing old issues

        Show
        arjen.poutsma Arjen Poutsma added a comment - Closing old issues

          People

          • Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            asutula Aaron Sutula
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0d
              0d
              Logged:
              Time Spent - 1m
              1m