Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-732

OSGi manifest version range for javax.servlet package import too restrictive

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.0.3
    • Component/s: None
    • Labels:
      None

      Description

      The Import-Package statement for javax.servlet and javax.servlet.http is currently [2.4.0, 3.0.0). Since spring-ws is compatible with Servlet 3, this should be opened to [2.4.0, 4.0.0).

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open In Progress In Progress
          8d 7h 57m 1 Arjen Poutsma 06/Oct/11 2:50 AM
          In Progress In Progress Resolved Resolved
          15m 48s 1 Arjen Poutsma 06/Oct/11 3:06 AM
          Resolved Resolved Closed Closed
          211d 3h 57m 1 Arjen Poutsma 04/May/12 7:03 AM

            People

            • Assignee:
              arjen.poutsma Arjen Poutsma
              Reporter:
              mpilquist Michael Pilquist
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0d
                0d
                Logged:
                Time Spent - 14m
                14m