Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-75

Java 1.5+ Constructor Used for IllegalStateException

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0 M3
    • Fix Version/s: 1.0 M3
    • Component/s: XML
    • Labels:
      None

      Description

      org.springframework.xml.stream.StaxEventXmlReader uses a constructor for IllegalStateException that is only available in Java 1.5 and later on line 68. If this is meant to be able to compile with earlier versions of the jdk, then the second parameter should be dropped.

        Attachments

          Activity

            People

            Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            gk5885 Gregory Kick
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: