Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-80

Building samples fails due to reference to parent project in pom.xml

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0 M2
    • Fix Version/s: 1.0 M3
    • Component/s: Samples
    • Labels:
      None
    • Environment:
      Ubuntu Linux 6.10, Maven 2.0.4, Sun JDK 1.5.0_08

      Description

      Trying to run mvn jetty:run target in the echo web service sample gives med the following error:

      [INFO] Scanning for projects...
      Downloading: http://repo1.maven.org/maven2/org/springframework/ws/spring-ws-samples/1.0-m2/spring-ws-samples-1.0-m2.pom
      [WARNING] Unable to get resource from repository central (http://repo1.maven.org/maven2)
      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Failed to resolve artifact.

      GroupId: org.springframework.ws
      ArtifactId: spring-ws-samples
      Version: 1.0-m2

      Reason: Unable to download the artifact from any repository

      org.springframework.ws:spring-ws-samples:pom:1.0-m2

      from the specified remote repositories:
      central (http://repo1.maven.org/maven2)

      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.reactor.MavenExecutionException: Cannot find parent: org.springframework.ws:spring-ws-samples for project: null:echo:war:null
      at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:365)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:278)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:115)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:256)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.project.ProjectBuildingException: Cannot find parent: org.springframework.ws:spring-ws-samples for project: null:echo:war:null
      at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1161)
      at org.apache.maven.project.DefaultMavenProjectBuilder.buildInternal(DefaultMavenProjectBuilder.java:674)
      at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal(DefaultMavenProjectBuilder.java:416)
      at org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMavenProjectBuilder.java:192)
      at org.apache.maven.DefaultMaven.getProject(DefaultMaven.java:515)
      at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:447)
      at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:351)
      ... 11 more
      Caused by: org.apache.maven.project.ProjectBuildingException: POM 'org.springframework.ws:spring-ws-samples' not found in repository: Unable to download the artifact from any repository

      I've tried to locate the spring-ws-samples, but can't find any POM describing the parent project.

        Activity

        arjen.poutsma Arjen Poutsma added a comment -

        Yes, the spring-ws-samples pom is missing from the download, unfortunately. You can download it here:

        https://svn.sourceforge.net/svnroot/springframework/spring-ws/tags/spring-ws-1.0-m2/spring-ws-samples/pom.xml

        Place that file in the samples directory (i.e. the parent dir of echo and airline), and everything should work.

        The next release (due this or next week) will contain this pom.


          People

          • Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            tronda Trond Andersen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: