Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-821

Not possible to create wrapped doc/literal wsdls with SuffixBasedPortTypesProvider

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.1.2
    • Fix Version/s: 2.1.3
    • Component/s: Core
    • Labels:
      None
    • Environment:
      N/A

      Description

      http://www.ibm.com/developerworks/webservices/library/ws-usagewsdl/index.html says that doc/literal wrapped style request elements should be named the same as the operation.

      4. Input Wrapper Element name should match with Operation name 
      The name of the input wrapper element must be the same as the web service operation name in WSDL.

      But it's not possible to set the request suffix to an empty string (and I also guess that the rest of the code could not work with an empty request suffix:

      Caused by: java.lang.IllegalArgumentException: 'requestSuffix' must not be empty
              at org.springframework.util.Assert.hasText(Assert.java:162)
              at org.springframework.ws.wsdl.wsdl11.provider.SuffixBasedMessagesProvider.setRequestSuffix(SuffixBasedMessagesProvider.java:61)

      AFAIK wrapped style is the de-facto standard (along with doc/literal) so it would be good if sws could support it.

        Activity

        davidkarlsen David J. M. Karlsen created issue -
        arjen.poutsma Arjen Poutsma made changes -
        Field Original Value New Value
        Fix Version/s 2.1.3 [ 13897 ]
        arjen.poutsma Arjen Poutsma made changes -
        Assignee Arjen Poutsma [ arjen.poutsma ]
        arjen.poutsma Arjen Poutsma added a comment -

        As the PortTypesProvider is an interface, it certainly is possible to implement a version that does follow the doc/literal conventions. There is even an AbstractPortTypesProvider to get you started.

        arjen.poutsma Arjen Poutsma made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        102d 21h 7m 1 Arjen Poutsma 04/Apr/13 4:36 AM

          People

          • Assignee:
            arjen.poutsma Arjen Poutsma
            Reporter:
            davidkarlsen David J. M. Karlsen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: