Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-858

Add programmatically support (Java config) for interceptors

    Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.1.4
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
      None

      Description

      Please add programmatically support (Java config) for interceptors.

      Until now the only way to register interceptors is via XML <sws:interceptors>.

      Since Spring 3 you have the AnnotationConfigApplicationContext and there is no need to force the usage of XML anymore.

      Possible solutions:

      1.) New interceptors array parameter for @PayloadRoot and @SoapAction annotations.
      2.) New interceptors annoation in combination with the @PayloadRoot or @SoapAction annotation.
      3.) A way to call setInterceptors() method of AbstractEndpointMapping after a @Endpoint annotated bean was initialized.

      Thank you

        Issue Links

          Activity

          arjen.poutsma Arjen Poutsma added a comment -

          Duplicate of SWS-836.


            People

            • Assignee:
              arjen.poutsma Arjen Poutsma
              Reporter:
              martin.wegner@ebp.de Martin Wegner
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: