Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-916

Wss4jSecurityInterceptor in spring-ws-security version 2.2.0 is not compatible with wss4j version 2.0.3

    Details

    • Type: Bug
    • Status: Open
    • Priority: Blocker
    • Resolution: Unresolved
    • Affects Version/s: 2.2.0.RELEASE
    • Fix Version/s: None
    • Component/s: Security
    • Labels:

      Description

      Wss4jSecurityInterceptor in spring-ws-security version 2.2.0.RELEASE is not compatible with wss4j version 2.0.3 which undergone package restructure.

      org.apache.ws.security.WSSecurityException is a java class in lower versions of wss4j jar and currently it is restructured to org.apache.wss4j.common.ext.WSSecurityException in wss4j version 2.0.3.

      So i'm getting class not found exception for org.apache.ws.security.WSSecurityException class when calling Wss4jSecurityInterceptor .

        Activity

        Hide
        gregturn Greg Turnquist added a comment -

        Spring WS is built against Wss4j 1.6.15. Moving to Wss4j 2.0.5 is a major breaking change.

        Show
        gregturn Greg Turnquist added a comment - Spring WS is built against Wss4j 1.6.15. Moving to Wss4j 2.0.5 is a major breaking change.

          People

          • Assignee:
            Unassigned
            Reporter:
            himaakishore Himaa Kishore D
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated: