Uploaded image for project: 'Spring Web Services'
  1. Spring Web Services
  2. SWS-994

Upgrade to Java 8, Spring 5, and everything else

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 3.0.0.RC1
    • Component/s: None
    • Labels:
      None

      Description

      Move the master branch to Spring Web Services 3.0, assuming usage of Java 8, Spring 5, and all other major upgrades.

      • Remove wss4j 1.x line, only using wss4j 2.x
      • Move all other libraries to latest stable versions
      • Upgrade to Gradle 4.0

        Activity

        gregturn Greg Turnquist created issue -
        gregturn Greg Turnquist made changes -
        Field Original Value New Value
        Status Open [ 1 ] In Progress [ 3 ]
        gregturn Greg Turnquist made changes -
        gregturn Greg Turnquist made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Complete [ 8 ]
        gregturn Greg Turnquist made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            gregturn Greg Turnquist
            Reporter:
            gregturn Greg Turnquist
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: