Uploaded image for project: 'Spring XD'
  1. Spring XD
  2. XD-2501

Upgrade to Boot 1.2.0 RELEASE and the dependencies

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Priority: Minor
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 1.1 GA
    • Component/s: None
    • Labels:
      None

      Description

      As a XD Admin, I'd like to upgrade to Spring Boot 1.2.0 RELEASE and the associated dependencies so that we can catch up with the latest features, bug-fixes and enhancements.

      Following XD dependencies needs upgraded to sync-up with Boot 1.2.0 RELEASE:

      <activemq.version>5.10.0</activemq.version>
      <aspectj.version>1.8.4</aspectj.version>
      <commons-dbcp2.version>2.0.1</commons-dbcp2.version>
      <h2.version>1.4.182</h2.version>
      <hibernate.version>dd4.3.7.Final</hibernate.version>
      <hibernate-validator.version>5.1.3.Final</hibernate-validator.version>
      <hikaricp.version>2.2.5</hikaricp.version>
      <hornetq.version>2.4.5.Final</hornetq.version>
      <httpasyncclient.version>4.0.2</httpasyncclient.version>
      <httpclient.version>4.3.6</httpclient.version>
      <jackson.version>2.4.4</jackson.version>
      <janino.version>2.6.1</janino.version>
      <jetty.version>9.2.4.v20141103</jetty.version>
      <jetty-jsp.version>2.2.0.v201112011158</jetty-jsp.version>
      <joda-time.version>2.5</joda-time.version>
      <jolokia.version>1.2.3</jolokia.version>
      <junit.version>4.12</junit.version>
      <liquibase.version>3.3.0</liquibase.version>
      <log4j.version>1.2.17</log4j.version>
      <log4j2.version>2.1</log4j2.version>
      <mockito.version>1.10.8</mockito.version>
      <mongodb.version>2.12.4</mongodb.version>
      <mysql.version>5.1.34</mysql.version>
      <reactor.version>1.1.5.RELEASE</reactor.version>
      <reactor-spring.version>1.1.3.RELEASE</reactor-spring.version>
      <servlet-api.version>3.1.0</servlet-api.version>
      <spring.version>4.1.3.RELEASE</spring.version>
      <spring-batch.version>3.0.2.RELEASE</spring-batch.version>
      <spring-data-releasetrain.version>Evans-SR1</spring-data-releasetrain.version>
      <spring-hateoas.version>0.16.0.RELEASE</spring-hateoas.version>
      <spring-mobile.version>1.1.3.RELEASE</spring-mobile.version>
      <spring-security.version>3.2.5.RELEASE</spring-security.version>
      <tomcat.version>8.0.15</tomcat.version>
      <undertow.version>1.1.1.Final</undertow.version>

        Attachments

          Activity

            People

            Assignee:
            dturanski David Turanski
            Reporter:
            sabby Sabby Anandan
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: