Uploaded image for project: 'Spring XD'
  1. Spring XD
  2. XD-2878

Using a newer version of a spring-xd dependency is ignored in packaging

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: To Do
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 1.1 GA
    • Fix Version/s: None
    • Component/s: Configuration, Runtime
    • Labels:
      None
    • Story Points:
      3
    • Rank (Obsolete):
      9223372036854775807

      Description

      When creating a new module with a dependeny which has a newer version than the one Spring-xd uses (in my example I use Jedis 2.6.1 and Spring-xd uses Jedis 2.5.2) the packaging ignores the dependency.

      Using the solution of spring-boot-maven-plugin, doesn't help because it will only include what you explicitly add to the include section (transitive dependencies are not included)

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            milo.nimrod Nimrod Milo
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: