Uploaded image for project: 'Spring XD'
  1. Spring XD
  2. XD-3066

Make Enum Conversions for ModuleOptions more lenient

This issue belongs to an archived project. You can view it, but you can't modify it. Learn more

    XMLWordPrintable

Details

    • Story
    • Status: Done
    • Minor
    • Resolution: Complete
    • 1.2 M1
    • None
    • CLI, Configuration
    • None

    Description

      If you have a an option --mode=textLine, presently the enum MUST be named textLine.

      I think it would improve the user-experience if we allowed users to pass in values such as:

      • --mode=textLine
      • --mode=text_line
      • --mode=TEXT_LINE

      Attachments

        Issue Links

          Activity

            People

              hillert Gunnar Hillert
              hillert Gunnar Hillert
              Archiver:
              tmarshall Trevor Marshall

              Dates

                Created:
                Updated:
                Resolved:
                Archived: