[IDE-1366] Bogus warning about deprecated class that isn't referenced Created: 12/Mar/15  Updated: 22/May/15  Resolved: 22/May/15

Status: Resolved
Project: Spring IDE
Component/s: None
Affects Version/s: 3.6.4.RELEASE
Fix Version/s: 3.7.0.RELEASE

Type: Bug Priority: Minor
Reporter: Dave Syer Assignee: Martin Lippert
Resolution: Fixed Votes: 2
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


 Description   

I think this one comes from the new Spring Boot property file support because it seems always to be deprecated @ConfigurationProperties classes. Example: https://github.com/spring-projects/spring-security-oauth/tree/master/tests/annotation/multi (warning about HttpMapperProperties.



 Comments   
Comment by Martin Lippert [ 24/Mar/15 ]

I can see this in one of my own projects as well, will dive into the details here.

Comment by Martin Lippert [ 22/May/15 ]

I think this is a duplicate of https://issuetracker.springsource.com/browse/STS-4126, and fixed now for the upcoming STS 3.7.0 release.

Generated at Sat Nov 23 02:15:08 UTC 2019 using Jira 7.13.8#713008-sha1:1606a5c1e7006e1ab135aac81f7a9566b2dbc3a6.