Ensure backwards compatibility with Spring 3.0 for Spring Integration 2.2 (INT-2689)

[INT-2690] Add suport for setting the Spring dependency version via Gradle Project Property Created: 26/Jul/12  Updated: 22/Aug/12  Resolved: 01/Aug/12

Status: Closed
Project: Spring Integration
Component/s: Build
Affects Version/s: None
Fix Version/s: 2.2 M4 Sprint 3, 2.2 M4

Type: Sub-task Priority: Minor
Reporter: Gunnar Hillert Assignee: Gunnar Hillert
Resolution: Complete Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


 Comments   
Comment by Gunnar Hillert [ 30/Jul/12 ]

Added the ability to provide a Gradle project property called 'springVersion' that allows for setting a different Spring dependency version, e.g.:

gradle clean build -PspringVersion=3.0.7.RELEASE
Comment by Gunnar Hillert [ 01/Aug/12 ]

Resolved with PR https://github.com/SpringSource/spring-integration/pull/566

Generated at Sat Jul 11 05:45:12 UTC 2020 using Jira 8.5.4#805004-sha1:0444eab799707f9ad7b248d69f858774aadfd250.