[ROO-3506] Compile fails on JDK 1.8 Created: 16/May/14  Updated: 16/May/14  Resolved: 16/May/14

Status: Resolved
Project: Spring Roo
Component/s: None
Affects Version/s: None
Fix Version/s: 1.3.0.RELEASE

Type: Bug Priority: Blocker
Reporter: Sascha Fröhlich Assignee: Enrique Ruiz (DiSiD)
Resolution: Duplicate Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Attachments: Text File log.txt    
Issue Links:
Relate
is related to ROO-3505 Spring Roo doesn't start with JDK 1.8 Resolved

 Description   

I am using Spring Roo 1.2.5.RELEASE on OS X 10.9.2 and java version 1.8.0_05.

I generated a project and added an entity with automatically generated integration tests. After triggering a "perform tests" the compile goal failed (complete log file attached):

[ERROR] The type java.lang.CharSequence cannot be resolved. It is indirectly referenced from required .class files
[ERROR] java.util.Arrays cannot be resolved to a type
[ERROR] The type java.util.Map$Entry cannot be resolved. It is indirectly referenced from required .class files

Changing the aspectj.version property in the pom.xml from 1.7.4 to 1.8.0 resolved the issue.



 Comments   
Comment by Alan Stewart [ 16/May/14 ]

Support for Jdk 1.8 will follow in a later release

Generated at Wed Jul 15 09:58:19 UTC 2020 using Jira 8.5.4#805004-sha1:0444eab799707f9ad7b248d69f858774aadfd250.