Spring Roo doesn't start with JDK 1.8 (ROO-3505)

[ROO-3553] Update Felix to 4.4.1 Created: 10/Nov/14  Updated: 19/Nov/14  Resolved: 19/Nov/14

Status: Resolved
Project: Spring Roo
Component/s: @ CORE
Affects Version/s: 1.2.5.RELEASE
Fix Version/s: 1.3.0.RELEASE

Type: Sub-task Priority: Blocker
Reporter: Enrique Ruiz (DiSiD) Assignee: Juan Carlos García del Canto
Resolution: Complete Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


 Description   

Update Felix to 4.4.1



 Comments   
Comment by Juan Carlos García del Canto [ 19/Nov/14 ]

Updating libraries to use Felix 4.4.1

Doing this updates, appeared some cycle references. To solve it, some @References were modified.

It is recommended not to use referenced elements on activate component methods to prevent errors if recerenced element still not loaded.

With so many changes, we decide to go to 1.3.0.RELEASE version instead of 1.2.6.RELEASE

Couldn't solve all cycle references on Gwt Addon so is not available on 1.3.0.RELEASE version. If you want to use Gwt Addon you must use 1.2.x ROO versions.

If someone wants to contribute on ROO project fixing all Gwt Addon cycle references is welcome!

Please, if you detect some error that appears on 1.3.0.RELEASE, report on JIRA to solve as quick as possible.

Generated at Fri Nov 15 03:30:39 UTC 2019 using Jira 7.13.8#713008-sha1:1606a5c1e7006e1ab135aac81f7a9566b2dbc3a6.