[ROO-867] perform shows no output in STS Created: 20/May/10  Updated: 23/Aug/10  Resolved: 18/Jun/10

Status: Closed
Project: Spring Roo
Component/s: @ ROO SHELL
Affects Version/s: 1.1.0.M1
Fix Version/s: 1.1.0.M2

Type: Bug Priority: Minor
Reporter: Philipp Walther Assignee: Christian Dupuis
Resolution: Complete Votes: 2
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Windows 7, 32bit // Java jdk 1.6.0_18 // maven 2.2.1


Issue Links:
Duplicate
is duplicated by ROO-1013 'perform test' does not run in STS Closed

 Description   

Looks a bit like ROO-392, but for the current downloadable version.

I did more or less what the introduction told me to.
When I execute perform tests I get:

    ____  ____  ____  
   / __ \/ __ \/ __ \ 
  / /_/ / / / / / / / 
 / _, _/ /_/ / /_/ /  
/_/ |_|\____/\____/    1.1.0.M1 [rev 3a0b8a3]


Welcome to Spring Roo. For assistance press CTRL+SPACE or type "hint" then hit ENTER.
roo> 
roo> 
perform tests
roo> 

Maybe this is an issue with my setup, here is what I did:
Download STS
Start STS
Go through tutorial
perform tests ==> mvn.bat not found.
Downloaded maven, add maven to PATH
perform tests
Restart STS
perform tests

No luck..



 Comments   
Comment by Philipp Walther [ 20/May/10 ]

This might be related to the SDK version installed, see [539]. I will retry with a newer SDK version, but [539] says it was fixed.

Comment by Philipp Walther [ 21/May/10 ]

I just did another test, on a different machine, different JDK version. Same result though.
Win7 32bit // JDK 1.6.0_20 // maven-2.2.1.RELEASE

Also rather strange: After I ran setup, I still need to add mvn to PATH?

Comment by Ben Alex [ 23/May/10 ]

This doesn't appear to be the same bug as ROO-392 (which in turn was a duplication of ROO-363) as we are still invoking Runtime.getRutime().exec(cmd, null, root) in 1.1.0.M1 (see http://static.springsource.org/spring-roo/org.springframework.roo.addon.maven/xref/org/springframework/roo/addon/maven/MavenCommands.html). I need to look into this some more.

Comment by Peter Laird [ 09/Jun/10 ]

I also am experiencing this.

Roo 1.1.0.M1 [rev 3a0b8a3]
Ubuntu 10.04
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) Server VM (build 16.3-b01, mixed mode)
Apache Maven 2.2.1

Comment by Ben Alex [ 17/Jun/10 ]

Would you please clarify if this is happening in the standalone Roo version, or when using the commands via the embedded STS Roo View? If via STS, would you mind launching STS from a command line window and then retrying, seeing if any errors messages appear on the console that loaded STS (and including them as a comment here). Thanks.

BTW I just used Roo 1.1.0.M1 "perform tests" with Ubuntu 10.04, Java 1.6.0_20, Maven 2.0.10 without any issue. Note this was the standalone version of Roo.

Comment by Ben Alex [ 17/Jun/10 ]

May be related to ROO-1013. Will await response from reporters of ROO-867 before marking ROO-1013 as a duplicate or not.

Comment by cometta [ 17/Jun/10 ]

i tried on sts and have similar problem. havent test on standalone

Comment by Philipp Walther [ 17/Jun/10 ]

It only occurs when using the console inside sts. Standalone works fine.
I'll run it from the command line and post results later.

Comment by Philipp Walther [ 17/Jun/10 ]

Oh and Ben or any admin: Could you fix the title of this bug? ouput.. This might prevent further duplicates..

Comment by Ben Alex [ 18/Jun/10 ]

Christian fixed this in Git commit 76d42f7f5b414c3507fc2e0f47927f94b2a5f207.

Generated at Sat Mar 23 21:07:39 UTC 2019 using JIRA 7.9.2#79002-sha1:3bb15b68ecd99a30eb364c4c1a393359bcad6278.