[SPRNET-126] ObjectsDtd class is inappropriately named Created: 12/Jul/05  Updated: 14/Sep/05  Resolved: 13/Jul/05

Status: Closed
Project: Spring.NET
Component/s: Spring-NET-CORE
Affects Version/s: 1.0 RC1
Fix Version/s: 1.0 RC1

Type: Task Priority: Trivial
Reporter: Rick Evans Assignee: Mark Pollack
Resolution: Fixed Votes: 1
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


The ObjectsDtd class is inappropriately named... it has a number of constants used by the XML parser to describe the elements and attributes of the XML object definition schema. It has zippo to do with a DTD.

Since we no longer use a DTD, but rather XML Schema, this class might be better off named ObjectSchemaConstants, or (better) something that is not tied to the validation mechanism (in the case that we should ever move to something else).

How about... ObjectDefinitionConstants? ObjectXmlConstants?

Votes and suggestions please.

Comment by Mark Pollack [ 13/Jul/05 ]

between the two I like, ObjectDefinitionConstants, though it is a bit long.

Comment by Rick Evans [ 13/Jul/05 ]

Renamed ObjectsDtd class to ObjectDefinitionConstants.

Generated at Fri Aug 14 15:20:38 UTC 2020 using Jira 8.5.4#805004-sha1:0444eab799707f9ad7b248d69f858774aadfd250.