[STS-1672] Xerces error when parsing beans xml Created: 18/Mar/11  Updated: 21/Jun/11  Resolved: 21/Mar/11

Status: Resolved
Project: Spring Tool Suite
Component/s: VALIDATION
Affects Version/s: 2.6.0.RELEASE
Fix Version/s: None

Type: Bug Priority: Major
Reporter: Will Tran Assignee: Christian Dupuis
Resolution: Complete Votes: 3
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Installed from springsource-tool-suite-2.6.0.RELEASE-e3.6.2-macosx-cocoa-x86_64-installer.dmg
JVM: Java HotSpot(TM) 64-Bit Server VM (19.1-b02-334, mixed mode)
Java: version 1.6.0_24, vendor Apple Inc. (Latest, update 4)
Mac OS X 10.6.6 Build 10J567


Attachments: Zip Archive sts-1672-patch.zip    

 Description   

Bean XML files can't be parsed due to Xerces insantiation error:

!ENTRY org.springframework.ide.eclipse.beans.core 1 0 2011-03-18 13:14:02.697
!MESSAGE Error occured processing 'beans.xml'
!STACK 0
org.apache.xerces.parsers.ObjectFactory$ConfigurationError: Provider org.apache.xerces.parsers.XIncludeAwareParserConfiguration could not be instantiated: org.apache.xerces.impl.dv.DVFactoryException: DTD factory class org.apache.xerces.impl.dv.dtd.DTDDVFactoryImpl does not extend from DTDDVFactory.
at org.apache.xerces.parsers.ObjectFactory.newInstance(Unknown Source)
at org.apache.xerces.parsers.ObjectFactory.createObject(Unknown Source)
at org.apache.xerces.parsers.ObjectFactory.createObject(Unknown Source)
at org.apache.xerces.parsers.DOMParser.<init>(Unknown Source)
at org.apache.xerces.parsers.DOMParser.<init>(Unknown Source)
at org.springframework.ide.eclipse.core.io.xml.LineNumberPreservingDOMParser.<init>(LineNumberPreservingDOMParser.java:40)
at org.springframework.ide.eclipse.core.io.xml.XercesDocumentLoader.loadDocument(XercesDocumentLoader.java:35)
at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:388)
at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:334)
at org.springframework.ide.eclipse.beans.core.internal.model.BeansConfig$2.loadBeanDefinitions(BeansConfig.java:375)
at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:302)
at org.springframework.ide.eclipse.beans.core.internal.model.BeansConfig$3.call(BeansConfig.java:421)
at org.springframework.ide.eclipse.beans.core.internal.model.BeansConfig$3.call(BeansConfig.java:1)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:680)

This happened after I upgraded from 2.5.2 to 2.6.0; I deleted my old STS and downloaded the install file for 2.6.0, but the error still happens.



 Comments   
Comment by Martin Lippert [ 18/Mar/11 ]

Leo, can you take a look what goes wrong here?

Comment by Leo Dos Santos (c) [X] [ 18/Mar/11 ]

Hi Will, do you have multiple versions of Apache Xerces in your project classpath?

Comment by Marino Borra [ 19/Mar/11 ]

I had the same problem. I removed (Maven dependency) the jar (xercesImpl 2.9.1) from the classpath and now it works, but it is not a solution for me.

Comment by Christian Dupuis [ 20/Mar/11 ]

I have a fix for that. Will release a feature patch on Monday.

Christian

Comment by Andrei Ivanov [ 21/Mar/11 ]

Is there any way to install 2.5.2? The update site seems to only contain the latest version.

I've tried reverting the upgrade in Eclipse but it seems to have failed and now I cannot get a usable Eclipse.

Comment by Andrei Ivanov [ 21/Mar/11 ]

Never mind, I found http://download.springsource.com/release/TOOLS/update/2.5.2.SR1/e3.6/springsource-tool-suite-2.5.2.SR1-e3.6-updatesite.zip, it should work

Comment by Christian Dupuis [ 21/Mar/11 ]

Hi,

I just published a fix for this to the STS Extension install (Open the STS Dashboard -> Extensions tab -> Select 'Patch for issue STS-1672' and click install).

For those of you with Spring IDE only, the patch can be installed from http://dist.springsource.com/release/TOOLS/patches/e3.6.

Let me know if you encounter any issues.

Christian

Comment by Will Tran [ 21/Mar/11 ]

Looks good, thanks for the quick response guys!

Comment by preben [ 23/Mar/11 ]

Installing from the extension tab gives error:

Problems occurred while performing installation: Operation details
Operation details
Cannot complete the install because one or more required items could not be found.
Software currently installed: SpringSource Tool Suite Grails Support 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201103161000-RELEASE)
Missing requirement: Eclipse RCP 3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY (org.eclipse.rcp.feature.group 3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY) requires 'org.eclipse.core.jobs [3.5.1.R36x_v20100824]' but it could not be found
Cannot satisfy dependency:
From: SpringSource Tool Suite (required) 2.6.0.201103161000-RELEASE (com.springsource.sts.feature.group 2.6.0.201103161000-RELEASE)
To: org.springframework.ide.eclipse.mylyn.feature.feature.group [2.6.0,3.0.0)
Cannot satisfy dependency:
From: SpringSource Tool Suite Grails Support 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201103161000-RELEASE)
To: com.springsource.sts.feature.group [2.6.0,2.7.0)
Cannot satisfy dependency:
From: Eclipse CVS Client 1.2.1.r362_v20101111-7B77FKv99HL0GvIAF99I8H14B7E (org.eclipse.cvs.feature.group 1.2.1.r362_v20101111-7B77FKv99HL0GvIAF99I8H14B7E)
To: org.eclipse.platform.feature.group 3.6.0
Cannot satisfy dependency:
From: Mylyn Bridge: Eclipse IDE 3.4.3.v20110131-0100-e3x-7G7J5BgJ9EC9QKN49E997JSm (org.eclipse.mylyn.ide_feature.feature.group 3.4.3.v20110131-0100-e3x-7G7J5BgJ9EC9QKN49E997JSm)
To: org.eclipse.cvs.feature.group [1.1.0,2.0.0)
Cannot satisfy dependency:
From: Eclipse Platform 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi (org.eclipse.platform.feature.group 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi)
To: org.eclipse.rcp.feature.group [3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY]
Cannot satisfy dependency:
From: Spring IDE Mylyn Integration (optional) 2.6.0.201103160035-RELEASE (org.springframework.ide.eclipse.mylyn.feature.feature.group 2.6.0.201103160035-RELEASE)
To: org.eclipse.mylyn.ide_feature.feature.group 3.0.0

Comment by Christian Dupuis [ 23/Mar/11 ]

perben, can you please provide more details on your configuration? How did you initially install STS? Can you post or attach your configuration details.

Christian

Comment by preben [ 29/Mar/11 ]

hey Christian

This is what i remember:
Had sts 3.5.latest upgraded to 3.6.0 using eclipse update.
Installed Grails using the extension tab.
Everything worked ok until I wanted to install bug fix using extension tab where I got the error.

I'm quite sure error only occurs when you have grails installed since I have upgrade other STS installation without any problem where Grails plugin wasn't installed.

/Preben

Comment by Duane Zamrok [ 29/Mar/11 ]

I was quite upset when I updated and my entire project started flashing red with errors.

It took me a little bit of time to find this ticket, but the patch worked perfectly.Thanks for the fast response!

Comment by Scott Parkerson [ 30/Mar/11 ]

Just a question: what's the best way to install this patch if you are using Eclipse Galileo (3.5) with STS 2.6.0 installed via update site? The patch doesn't show up in my Dashboard -> Extensions tab.

Comment by stuart law [ 31/Mar/11 ]

hey Christian,

Thanks for the patch and sorry to be a pain but is it available from anywhere other than amazon s3 storage? This domain is completely blocked at my workplace (not your problem I realise). I'm using full STS 2.6.0 RELEASE build 201103161000. Could it be attached to this JIRA?

Stuart

Comment by Martin Lippert [ 31/Mar/11 ]

I attached the update site as archive.
You can directly select this archive (without unzipping it before) from the update-manager within STS.

HTH,
Martin

Comment by stuart law [ 05/Apr/11 ]

Thanks Martin.
Worked fine, much appreciated.
Stuart

Comment by Arata Yamamoto [ 20/Apr/11 ]

Dear Christian,
I use Spring IDE (Not STS yet) and cannot install the patch from http://dist.springsource.com/release/TOOLS/patches/e3.6 because of access denied error.
Would you mind asking attach the patch for Spring IDE to this JIRA too?
Or I wonder if I can apply the attached STS patch on Spring IDE too, if so, then could you tell the instructions kindly?

Regards,
Art

Comment by Arata Yamamoto [ 20/Apr/11 ]

Please never mind for my previous comment.
I figured out how to apply the patch fro the attached sts-1672-patch.zip file onto Spring IDE.
Thank you for the patch.
Art

Comment by Michael Yockey [ 21/Jun/11 ]

I'm experiencing this problem on the Win32 platform. Is there an update forthcoming for Spring IDE to correct this?

Comment by Martin Lippert [ 21/Jun/11 ]

Hi Michael!

You can upgrade to 2.7.0.M2 (the latest published milestone build of STS/Spring IDE) or wait for the 2.7.0 release of both, which is scheduled for the beginning of July.

HTH,
Martin

Generated at Sun Sep 23 17:56:53 UTC 2018 using JIRA 7.9.2#79002-sha1:3bb15b68ecd99a30eb364c4c1a393359bcad6278.