[STS-2353] breakpoint is not getting triggered when set on an aspectj controller file. Created: 23/Dec/11  Updated: 07/Apr/17  Resolved: 07/Apr/17

Status: Closed
Project: Spring Tool Suite
Component/s: ROO
Affects Version/s: 2.8.1.RELEASE
Fix Version/s: None

Type: Bug Priority: Trivial
Reporter: Venkat Ganesh Assignee: Unassigned
Resolution: Won't Fix Votes: 0
Labels: aspectj, roo, sts
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

sun java version "1.6.0_30". Roo 1.1.5.RELEASE [rev d3a68c3]. Linux 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:28:43 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

SpringSource Tool Suite
Version: 2.8.1.RELEASE
Build Id: 201111221000



 Description   

Set a break point in _Controller.aj file, an example shown below.
FooController_Roo_Controller [entry] - FooController.update(Foo, BindingResult, Model, HttpServletRequest)
FooController_Roo_Controller [entry] - FooController.updateForm(Long, Model)

Test the application and I am able to verify the break point is not getting triggered in STS IDE 2.8.1.

Workaround:

Cut the methods from FooController_Roo_Controller.aj and move it to FooController_Roo.java and repeat the exercise. Now I am able to verify the break points do get triggered.

I remember break points even when placed in the aj files getting triggered but that was long back. Can't remember in which version it worked and when it stopped working.

Thanks,



 Comments   
Comment by Andrew Eisenberg [ 06/Jan/12 ]

Hi Venkat,

Apologies for not responding earlier, but your issue was reported right before the holidays and slipped through.

I can try to reproduce using just the information you give me, but it would be helpful if you could attach the affected files.

Comment by Andrew Eisenberg [ 06/Jan/12 ]

I tried reproducing using the standard petclinic app. I set breakpoints at PetController.updateForm and PetController.update. Both breakpoints were hit as expected.

Are you running the AspectJ compiler with all default options? Also, in both cases, was the roo app functioning normally? Lastly, did you see any errors in your error log?

Comment by Martin Lippert [ 07/Apr/17 ]

This project has moved its issue management to GitHub Issues:
https://github.com/spring-projects/spring-ide/issues

Therefore we closed the majority of old issues, like this one here. If you think this issue is still valid and should be fixed or worked on, please feel free to file it as a new issue on GitHub (using the link above).

Generated at Tue Dec 10 11:05:55 UTC 2019 using Jira 7.13.8#713008-sha1:1606a5c1e7006e1ab135aac81f7a9566b2dbc3a6.