[SWF-1182] Upgrade to Spring Security 3.0 Created: 21/Oct/09  Updated: 04/May/10  Resolved: 21/Apr/10

Status: Resolved
Project: Spring Web Flow
Component/s: Integration: Security
Affects Version/s: 2.0.8
Fix Version/s: 2.1.0.M1

Type: Task Priority: Major
Reporter: Keesun Baik Assignee: Rossen Stoyanchev
Resolution: Complete Votes: 8
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Attachments: File SecurityFlowExecutionListener.java    
Issue Links:
Depends
is depended on by ROO-571 Webflow integration does not work for... Closed

 Description   

I'm using Spring Security 3.0 but SecurityFlowExecutionListener class is work on Spring Security 2.X.
So I had fix a little codes from original. If you have a plan that upgrade dependecy to Spring Security 3.0, confirm this patch please.



 Comments   
Comment by Keith Donald [ 29/Mar/10 ]

Needs to be backwards compatible with Spring Security 2 as well.

Comment by Rossen Stoyanchev [ 21/Apr/10 ]

Modified the subject to encompass the more general goal of upgrading to Spring Security 3. Original subject was "SecurityFlowExecutionListener patch for Spring Security 3.0".

Generated at Tue Sep 17 23:28:34 UTC 2019 using JIRA 7.9.2#79002-sha1:3bb15b68ecd99a30eb364c4c1a393359bcad6278.