[SWS-484] Missing version qualifiers on Export-Package entries Created: 11/Feb/09  Updated: 04/May/12  Resolved: 20/May/09

Status: Closed
Project: Spring Web Services
Component/s: Core, OXM, Security, XML
Affects Version/s: 1.5.6
Fix Version/s: 1.5.7

Type: Bug Priority: Minor
Reporter: David Ciarletta Assignee: Arjen Poutsma
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Java 1.5 + Equinox OSGi + Spring + Spring-dm + Spring-WS + Spring-Integration


Reference URL: http://forum.springframework.org/showthread.php?t=67269

 Description   

The packages exported by the the spring-ws v1.5.6 modules do not contain the version qualifier so the osgi framework recognizes their version as "0.0.0". This caused the import-package for the oxm packages in the spring-integration bundles to fail because they are looking for version range [1.5.5.A,2.0.0).



 Comments   
Comment by Arjen Poutsma [ 04/May/12 ]

Closing old issues

Generated at Wed Dec 13 22:28:45 UTC 2017 using JIRA 6.4.14#64029-sha1:ae256fe0fbb912241490ff1cecfb323ea0905ca5.