[SWS-578] Fix manifest to disallow usage of org.springframework.oxm version 3.0.0 Created: 21/Oct/09  Updated: 04/May/12  Resolved: 05/Jan/10

Status: Closed
Project: Spring Web Services
Component/s: Core
Affects Version/s: 1.5.8
Fix Version/s: 1.5.9

Type: Bug Priority: Major
Reporter: Eric Berry Assignee: Arjen Poutsma
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: 0d
Time Spent: 1h 32m
Original Estimate: Not Specified
Environment:

Spring-WS 1.5.8.A, from the EBR (http://www.springsource.com/repository/app/bundle/version/detail?name=org.springframework.ws&version=1.5.8.A)



 Description   

The manifests of bundles org.springframework.ws and org.springframework.ws.java allow the use of org.springframework.oxm;version="[1.5.8,3.1.0)". Since Spring-ws 1.5.8 is incompatible with the OXM library in Spring 3.0, this is incorrect. The manifest needs to be modified to org.springframework.oxm;version="[1.5.8,2.0.0)".



 Comments   
Comment by Eric Berry [ 22/Oct/09 ]

Just so you catch everything:

org.springframework.ws imports
org.springframework.oxm;version="[1.5.8.A, 3.1.0)"
org.springframework.oxm.mime;version="[1.5.8.A, 3.1.0)"

org.springframework.ws.java5 imports
org.springframework.oxm;version="[1.5.8.A, 3.1.0)"

Comment by Arjen Poutsma [ 05/Jan/10 ]

Should be fixed now, thanks for providing a solution!

Comment by Arjen Poutsma [ 04/May/12 ]

Closing old issues

Generated at Thu Dec 14 04:09:24 UTC 2017 using JIRA 6.4.14#64029-sha1:ae256fe0fbb912241490ff1cecfb323ea0905ca5.