[SWS-599] Change API to use Java 5+ Created: 31/Jan/10  Updated: 04/May/12  Resolved: 24/Feb/10

Status: Closed
Project: Spring Web Services
Component/s: None
Affects Version/s: None
Fix Version/s: 2.0 M1

Type: Task Priority: Major
Reporter: Arjen Poutsma Assignee: Arjen Poutsma
Resolution: Complete Votes: 0
Labels: None
Remaining Estimate: 2d
Time Spent: Not Specified
Original Estimate: 2d


 Description   

This includes using:

  • @Override
  • Enums
  • varargs

In a backwards compatible fashion.

We also should start upgrading unit tests to use JUnit 4.8 and Easymock 2, but it's probably best to do that incrementally.



 Comments   
Comment by Arjen Poutsma [ 24/Feb/10 ]

The majority of the code base is now using Java 5 features. However, I'm sure there are places I've missed, and which will be resolved later.

Comment by Arjen Poutsma [ 04/May/12 ]

Closing old issues

Generated at Thu Dec 14 04:21:05 UTC 2017 using JIRA 6.4.14#64029-sha1:ae256fe0fbb912241490ff1cecfb323ea0905ca5.