[SWS-789] SoapEnvelopeLoggingInterceptor won't log Created: 23/Jul/12  Updated: 07/Aug/12  Resolved: 07/Aug/12

Status: Resolved
Project: Spring Web Services
Component/s: None
Affects Version/s: 2.1 GA
Fix Version/s: 2.1.1

Type: Bug Priority: Minor
Reporter: Lino Cibran Assignee: Arjen Poutsma
Resolution: Cannot Reproduce Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


 Description   

The SoapEnvelopeLoggingInterceptor does not log request/responses.

I'm using 2.1.0.RELEASE spring-ws-core, with the SoapEnvelopeLoggingInterceptor as the first/only interceptor (I usually have the payload and validation interceptors also).

<!-- ordered(!) list of interceptors -->
<sws:interceptors>
	
	<bean id="soapInterceptor"
		class="org.springframework.ws.soap.server.endpoint.interceptor.SoapEnvelopeLoggingInterceptor">
		<property name="logFault" value="true" />
		<property name="logRequest" value="true" />
		<property name="logResponse" value="true" />			
	</bean>

and setting log4j level to debug on org.springframework.ws.server.endpoint.interceptor to debug.

If I add the PayloadLoggingInterceptor, I can see the Payload request/responses. I don't see the soap request/response or fault logging.



 Comments   
Comment by Arjen Poutsma [ 07/Aug/12 ]

I've tried to reproduce this, but the SoapEnvelopeLoggingInterceptor works fine in my tests.

Generated at Sat Jul 21 15:50:18 UTC 2018 using JIRA 7.9.0#79000-sha1:3ca552e944c2fe83b21589bc06f155b9b428cc2b.