[SWS-916] Wss4jSecurityInterceptor in spring-ws-security version 2.2.0 is not compatible with wss4j version 2.0.3 Created: 16/Sep/15  Updated: 17/Sep/15

Status: Open
Project: Spring Web Services
Component/s: Security
Affects Version/s: 2.2.0.RELEASE
Fix Version/s: None

Type: Bug Priority: Blocker
Reporter: Himaa Kishore D Assignee: Unassigned
Resolution: Unresolved Votes: 1
Labels: Spring
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


 Description   

Wss4jSecurityInterceptor in spring-ws-security version 2.2.0.RELEASE is not compatible with wss4j version 2.0.3 which undergone package restructure.

org.apache.ws.security.WSSecurityException is a java class in lower versions of wss4j jar and currently it is restructured to org.apache.wss4j.common.ext.WSSecurityException in wss4j version 2.0.3.

So i'm getting class not found exception for org.apache.ws.security.WSSecurityException class when calling Wss4jSecurityInterceptor .



 Comments   
Comment by Greg Turnquist [ 17/Sep/15 ]

Spring WS is built against Wss4j 1.6.15. Moving to Wss4j 2.0.5 is a major breaking change.

Generated at Sat Nov 23 01:04:55 UTC 2019 using Jira 7.13.8#713008-sha1:1606a5c1e7006e1ab135aac81f7a9566b2dbc3a6.